Fix for OpenSSL error on Ruby

When rails new app, I’m getting errors:

require': cannot load such file -- openssl (LoadError)

To fix this, redownload the ruby source code again.

$wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p194.tar.gz
$tar xzvf ruby-1.9.3-p194.tar.gz
$cd ruby-1.9.3-p194/ext/openssl
$ruby extconf.rb
$make
$make install
Advertisements